Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Fixing no public key errors in linux

#1
So while I was setting up Pop! OS to do some software compiling I ran into a few issues.

the biggest of which was an error that looked like this: (NO_PUBKEY)

now what that means is either through network issues or other problems the public key for a repository to match the key to safeguard the repository is not available.

in my case it was because I needed the Xenial repositories for some libraries I need to compile stuff.

I tried a few different fixes but nothing worked so I went and tried the most manual and direct way short of going into they keychain and manually dropping it in there, provided i had the key...

I used the following Command, edited for the keys the error indicated I needed.

sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net:80 --recv-keys THE_MISSING_KEY_HERE

you need to do this for each key missing but it works well, hopefully this will prove useful to people looking for how to fix this.
"I reject your reality and subsitute my own." - Adam Savage, Mythbusters
[Image: 5.jpg]
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Programmable key input devices SpookyZalost 11 5,094 September 20th, 2019 at 8:06 PM
Last Post: SpookyZalost



Users browsing this thread: 1 Guest(s)

Makestation Theme/Design Selector

Contact Us | Makestation | Return to Top | Lite (Archive) Mode | RSS Syndication 
Proudly powered by MyBB 1.8, © 2002-2021
Forum design by Makestation Team © 2020
Saturn-Moon.com - a modern day time capsule | Makestation Ajax Chat Hosting